Lunascape ver 6.4.6 Release: Gecko Update to 3.6 Series

Yes, I understand. You must be thinking why not 4.0 series?!

Three weeks ago, we have released Lunascape ver.6.4.3, whose Gecko engine version tentatively rolled back to 3.5 series due to some conditional bugs. And now, we have fixed those bugs and updated the Gecko version back to 3.6 series in Lunascape ver.6.4.6.

We are aware that many of Lunascape users are waiting for the Gecko update to 4.0 series, especially after the Firefox 4.0 release. Let me just say that we are working on it, but will not suddenly update it to 4.0 series neither, as long as the 3.6 series are still in support. Instead, you will be able to pick and choose your preferred Gecko version to use with the Lunascape browser. For now, that is our plan. So, please stay tuned.

Download the latest Lunascape browser

Advertisements

One thought on “Lunascape ver 6.4.6 Release: Gecko Update to 3.6 Series

  1. Pingback: Обновление: Lunascape 6.4.6 Orion | RSS.NET.UA

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s